Need help? Call us on 1300 789 260

Your PHP installation appears to be missing the MySQL extension

Difficulty: Beginner

Overview

If you have moved your website recently to newer hosting or updated your PHP version to 7.0, you may see the following error:

Your PHP installation appears to be missing the MySQL extension which is required by WordPress.

This is because your version of WordPress is out of date . Prior to version 3.9, WordPress would only check for the PHP " mysql " extension.

More recent versions of PHP now use mysqli and mysqlnd , since the old mysql extension has been deprecated since PHP 5.5 and now completely removed in PHP 7.0.

To Fix

You need to update your website to the latest WordPress version. To do this, you may need to temporarily drop your PHP version back to something 5.6 or lower which will still have the old mysql extension.

Note: Leaving your website on an older WordPress version is NOT recommended. You should always keep the core of WordPress as well as any themes and plugins up-to-date.

Was this article helpful? Yes No
👥

Having trouble? We’re here to help!

We’ve built our company with a serious focus on quality service. Feel free to give us a call!

1300 789 260