Need help? Call us on 1300 789 260

TLS 1.2 Support

Difficulty: Intermediate

Overview

Many of the eCommerce and online payment systems (such as PayPal and eWay) are now enforcing TLS 1.2 for their encryption. You may receive a notice from your payment provider stating that TLS 1.0 is no longer supported.

The emails may be entitled such things as:

  • " Merchant Action Required: Upcoming TLS Structure Changes " (eWay)
  • " Security-Related Changes Required To Avoid Service Disruption " (PayPal)

Note : All Conetix hosting services support TLS 1.2. No server side changes are required.

This doesn't relate to an SSL certificate for your site, but is related to the connection from your server to the payment gateway providers and other similar financial systems.

Instructions

To ensure your system is using the latest TLS 1.2 protocol, there are a number of steps you can take (depending on your particular system). In all instances, the code making the request needs to enforce TLS.

Warning: Make sure you take a backup of your site before making any changes!

Here's what you can do to check:

  1. Contact your developer if you currently have someone maintaining or devleoping your website. They should be aware of the changes and have probably already implemented them for you.
  2. Upgrade any payment plugins you have. If you're running WordPress / WooCommerce, this can be done through the WordPress Admin system.
  3. Check any PHP code to ensure the calls via cURL enforce TLS 1.2. This should look like:
    curl_setopt($curl, CURLOPT_SSLVERSION, 6);
    
    If you use any other library for remote calls, you will need to check any specific code to ensure it also enforces TLS 1.2.

Was this article helpful? Yes No
👥

Having trouble? We’re here to help!

We’ve built our company with a serious focus on quality service. Feel free to give us a call!

1300 789 260