Need help? Call us on 1300 789 260

Is my version of cURL out of date?

Difficulty: Beginner

Overview

A recent update to the Yoast plugin for WordPress has been warning customers that their version of cURL is out-of-date and that their license update may fail.

This is incorrect.

On all managed Virtual Private Servers and shared hosting platforms, Conetix updates the latest version of all system level packages which includes cURL.  We use CentOS as our core operating system, which maintains version stability for each package. This means that updates can be applied without any impact on website stability and functionality. This is a feature , not an issue. If there are bugs or security issues fixed in newer versions, these are backported by the Red Hat and CentOS teams.

Why is the error generated?

Unfortunately, the developers of Yoast have taken the quick option to warn customers rather than the more comprehensive option of testing to ensure it works first.

There is an unresolved issue raise with Yoast about the warning here: https://github.com/Yoast/License-Manager/issues/75

Can I ignore the error?

If you are hosted with Conetix, Yes. The packages which we use (standard CentOS 7) is compatible with the Yoast License Manager.

Was this article helpful? Yes No
👥

Having trouble? We’re here to help!

We’ve built our company with a serious focus on quality service. Feel free to give us a call!

1300 789 260