Need help? Call us on 1300 789 260

Does Conetix Support APC for PHP?

Difficulty: Intermediate

Overview

Conetix does not provide support for the Alternative PHP Cache (APC) nor APCu out of the box, as it's not a standard PHP component. However, it's important to look at what part of the caching you're actually after. There's also OPCache, which became standard in PHP 5.5 and above and standard on all Conetix hosting plans. Here's a summary of the differences:

  • APC is both opcode and data store cache
  • APCu is data store cache only
  • OPCache is opcode cache only

If you're looking for APC to speed up your PHP code through the use of opcode caching, this is better handled by the OPCache. All you need to do is select PHP 5.5 or above, using our guide here: https://www.conetix.com.au/support/article/select-different-php-version-plesk-onyx

If you require APCu for user data caching, this would require a Virtual Private Server (VPS) and custom configuration. This is supported by PHP 5.4 only for our standard CentOS 7 systems.

Was this article helpful? Yes No
👥

Having trouble? We’re here to help!

We’ve built our company with a serious focus on quality service. Feel free to give us a call!

1300 789 260