← Back to the Blog

Australian Remi Repository

By Tim Butler
Australian Remi Repository

Conetix is proud to announce that we are hosting the Australian mirror for the Remi repository, which provides updated PHP and MySQL packages for Red Hat, CentOS and Fedora based systems. We’re proud to be able to assist web developers and system administrators in our region, so this is just one of the many ways we’re giving back to the community.

Official mirror site: remi.conetix.com.au

As long as you have the Yum FastestMirror plugin enabled, yum will automatically select this mirror if it’s the fastest available for you. For Australian, New Zealand and many other SE Asia sites, this should speed up the downloads of packages from the Remi repository for you.

For those who haven’t used Remi’s repository yet, this is the easiest way to install the latest PHP (eg PHP 5.4 or PHP 5.5) on your Red Hat server. At Conetix, this is the repository we use to ensure we’re running an up-to-date version of PHP for our servers.

If you want to install the repository, please have a good read of the instructions here.

As an example, here’s how you’d install PHP 5.4 on a CentOS 6.5 server:

  1. Ensure you have the Extra Packages for Enterprise Linux (EPEL) repository installed first. You can install this by running:
    rpm -Uvh http://download.fedoraproject.org/pub/epel/6/i386/epel-release-6-8.noarch.rpm
  2.  Install the Remi repository:
    rpm -Uvh http://rpms.famillecollet.com/enterprise/remi-release-6.rpm
  3. If you would like to use the repository by default, firstly you need to enable it. You can do this by editing the /etc/yum.repos.d/remi.repo and setting “enabled=1” for the repository.  
    Note: There is more than one repository contained within the file. Ensure you’re only enabling the repositories which you require.
  4. The remi.repo should look like this:
    name=Les RPM de remi pour Enterprise Linux 6 - $basearch
  5. Now you can update to PHP 5.4 via yum:
    yum install php
  6. Check for any errors in the yum output, otherwise you should now have PHP 5.4 installed.

A thanks again to Remi, who has created the repository and compiles the packages free for everyone to use. You can personally thank him by a donation or comment via his Thanks page.